System requirements

Before you install Shopware 6, you should check that your server meets the system requirements. In this article, we will show you what requirements your server should have.

System requirements

Operating system

Shopware generally supports most Unix-based operating systems. From experience, we recommend installing Shopware 6 on Linux (e.g. Ubuntu).

Please note that Shopware is not designed to run on a Windows server.

Please note that the requirements listed below are the minimum system requirements. Depending on how the shop is used (extensions, number of products, etc.), it is advisable to increase these accordingly.

Environment

PHP

  • Version 8.1 or higher 

  • memory_limit 512M or higher

  • max_execution_time 30 seconds or higher

Extensions:

  • ext-curl

  • ext-dom

  • ext-fileinfo

  • ext-gd

  • ext-iconv

  • ext-intl

  • ext-json

  • ext-libxml

  • ext-mbstring

  • ext-openssl

  • ext-pcre

  • ext-pdo

  • ext-pdo_mysql

  • ext-phar

  • ext-simplexml

  • ext-sodium

  • ext-xml

  • ext-zip

  • ext-zlib

SQL

  • MySQL 8.0.17 or higher
    MySQL versions 8.0.20 and 8.0.21 are not compatible due to technical problems in these versions.

or

  • MariaDB 10.3.22 or higher
    MariaDB versions 10.3.29, 10.4.19, 10.5.10 are not compatible due to technical problems in these versions.

Please note that the database user used for the Shopware installation has all preveligies for the tables and the database. Preveligies on the server level are not required. 

GIT
For version 6.5.0.0 or if you want to update from version 6.4 to version 6.5.0.0 and above, a git client must be installed on the server and a connection to our git repository has to be possible.
An update will fail without the git client and connection to the repository.

Other

  • Apache 2.4 or higher with active mod-rewrite

  • NGINX can also be used as a web server.

    Further details can be found in the developer docs.

  • Zend Opcache 256M or higher

  • APCu 128M or higher

  • Webserver with HTTP2 support

  • For database administration, we recommend Adminer (https://www.adminer.org/) because it has better support for binary data types.

Further compatibilities

  • Opensearch 1.0 or higher
  • Elasticsearch 7.8 or higher
  • Redis 5.0 or higher
  • Varnish version 6 or higher
  • node-js version 18.x.x or higher



 

Was this article helpful?