System Requirements

Before you install Shopware 6, you should check that your server meets the system requirements. In this article we will show you what requirements your server should have.

System requirements

Operating system

Shopware generally supports most Unix-based operating systems. From experience we recommend to install Shopware 6 on Linux (e.g. Ubuntu).

Please note that Shopware is not designed to run on a Windows server.

Environment

PHP

  • Version 7.4.3 or higher

  • memory_limit 512M or higher

  • max_execution_time 30 seconds or higher

Extensions:

  • ext-dom

  • ext-fileinfo

  • ext-gd

  • ext-iconv

  • ext-intl

  • ext-json

  • ext-libxml

  • ext-mbstring

  • ext-openssl

  • ext-pcre

  • ext-pdo

  • ext-pdo_mysql

  • ext-phar

  • ext-simplexml

  • ext-sodium

  • ext-xml

  • ext-zip

  • ext-zlib

SQL

  • MySQL 5.7.21 or higher
    MySQL versions 8.0.20 and 8.0.21 are not compatible due to technical problems in these versions.

or

  • MariaDB 10.3.22 or higher
    MariaDB versions 10.3.29, 10.4.19 and 10.5.10 are not compatible due to technical problems in these versions.

Other

  • Apache 2.4 or higher with active mod-rewrite

  • Zend Opcache 256M or higher

  • APCu 128M or higher

  • Webserver with HTTP2 support

  • For database administration we recommend Adminer (https://www.adminer.org/) because it has better support for binary data types.

 

Further compatibilities

  • Elasticsearch 7.8 or higher

  • Redis 5.0 or higher

  • Varnish version 6 or higher

  • node-js version 12 to 16 


 

Was this article helpful?