Systemvoraussetzungen

Bevor Du Shopware 6 installierst, solltest Du überprüfen, ob Dein Server die benötigten Systemanforderungen erfüllt. In diesem Artikel zeigen wir Dir welche Voraussetzungen Dein Server haben sollte.

Systemvoraussetzungen

Betriebssystem

Shopware unterstützt generell die meisten Unix basierten Betriebssysteme. Erfahrungsgemäß empfehlen wir aber Shopware 6 auf einer Linux-Umgebung (z.B. Ubuntu) zu installieren.

Bitte beachte, dass Shopware nicht für den Betrieb auf einem Windows-Server konzipiert ist.

Bitte beachte, dass die folgenden Voraussetzungen als minimale Systemanforderungen gelten. Es wird empfohlen, diese je nach Nutzung des Shops (z.B., durch Hinzufügen von Erweiterungen, steigende Produktanzahl) zu erhöhen.

Umgebung

PHP

  • Version 8.1 oder höher

  • memory_limit 512M oder höher

  • max_execution_time 30 Sekunden oder höher

Extensions:

  • ext-curl

  • ext-dom

  • ext-fileinfo

  • ext-gd

  • ext-iconv

  • ext-intl

  • ext-json

  • ext-libxml

  • ext-mbstring

  • ext-openssl

  • ext-pcre

  • ext-pdo

  • ext-pdo_mysql

  • ext-phar

  • ext-simplexml

  • ext-sodium

  • ext-xml

  • ext-zip

  • ext-zlib

SQL

  • MySQL 8.0.17 oder höher
    Die MySQL Versionen 8.0.20 und 8.0.21 sind aufgrund von technischen Problemen in diesen Versionen nicht kompatibel. 

oder

  • MariaDB 10.3.22 oder höher
    Die MariaDB Versionen 10.3.29, 10.4.19, 10.5.10 sind aufgrund von technischen Problemen in diesen Versionen nicht kompatibel. 

Bitte beachte, dass der verwendete Datenbank-Benutzer für die Shopware Installation alle Privilegien für die Tabellen und die Datenbank besitzt. Privilegien auf Server Ebene sind nicht erforderlich. 

GIT
Ab Version 6.5.0.0 oder für ein Update von einer 6.4er Version auf die Version 6.5.0.0 muss auf dem Server ein GIT Client installiert sein sowie ein Zugriff auf unser GIT Repository möglich sein.
Ohne den Client oder Zugriff wird ein Update mit einer Fehlermeldung abbrechen.

Sonstiges

  • Apache 2.4 oder höher mit aktiviertem mod-rewrite

  • NGINX kann ebenfalls als Webserver verwendet werden.

    Weitere Details hierzu findest Du in den Entwickler Docs

Empfohlen

  • Zend Opcache 256M oder höher

  • APCu 128M oder höher

  • Webserver mit HTTP2 Unterstützung

  • Für die Datenbank Administration empfehlen wir Adminer (https://www.adminer.org/), da dieser eine bessere Unterstützung von binary data types hat. 

Weitere Kompatibilitäten

  • Opensearch 1.0 oder höher
  • Elasticsearch 7.8 oder höher
  • Redis 5.0 oder höher
  • Varnish Version 6 oder höher
  • node-js ab Version 18

War dieser Artikel hilfreich?