Security Update 10/2017

General information

Next to the usual bug fixes and optimisations, we have also been able to close three moderate vulnerabilities.
All Shopware Versions from 5.0.0 up to 5.3.3 are affected.

The following vulnerabilities are fixed with this release.

  • SW-19834: Authenticated Backend and persistent XSS
  • SW-19895: Authenticated Backend SQL Injection
  • SW-19896: Authenticated Backend XXE

You can choose between two options, to protect your system:


We strongly recommend to update to the latest version of Shopware(5.3.4). This Version will fix these vulnerabilities. You can use the auto-update process or simply download the version over our download-page.

Install / update the security plugin

If it is not possible for you to update to the latest version of Shopware, you can use our Shopware Security-Plugin.

  • Download the Shopware Security Plugin from our store or use the Plugin Manager of your Shopware backend.
  • Install and activate the plugin.

If you use this plugin already, simply update it to the latest version to secure your environment.

Was this article helpful?