Security Update 10/2017

Version

5.0.0 - 5.3.3

Inhaltsverzeichnis

Allgemeine Informationen

In diesem Sicherheitsrelease haben wir neben den gewohnten Fehlerkorrekturen und Optimierungen auch drei Sicherheitslücken der Bedrohungsstufe „moderat“ schließen können.
Betroffen sind die Shopware Versionen von 5.0.0 bis einschließlich 5.3.3.

Folgende Sicherheitslücken, wurden mit diesem Sicherheitsupdate behoben:

  • SW-19834: Authentifizierte persistente XSS im Backend
  • SW-19895: Authentifizierte SQL Injection im Backend
  • SW-19896: Authentifizierte XXE im Backend

Um Dein System abzusichern, kannst Du nun zwischen den folgenden Optionen wählen:

Lösungen

Update der Shopware-Installation (Empfohlen)

Wir empfehlen ein Update auf die aktuelle Version 5.3.4 durchzuführen. Das Update auf 5.3.4 kannst Du regulär über den Auto-Updater beziehen oder direkt über unsere Download-Übersicht

Security Plugin installieren / updaten

Falls Du deine Shopware-Installation nicht updaten kannst (empfohlen), kannst Du die Absicherung ebenso per Plugin vornehmen:

  • Lade Dir das Shopware Sicherheits-Plugin über den Store herunter oder alternativ direkt über den Plugin-Manager im Backend.
  • Installiere und aktiviere das Plugin

Falls das Plugin bereits vorhanden ist, kannst Du das Plugin einfach über den Plugin-Manager updaten, um es auf den neuesten Stand zu bringen.