Security Update 01/2018

Article Version

5.2.0 - 5.3.6

Table of contents

General information

Next to the usual bug fixes and optimisations, we have also been able to close two moderate vulnerabilities.
All Shopware Versions from 5.2.0 up to 5.3.6 are affected. The following vulnerabilities are fixed with this release.

  • SW-20878: Non-Persistent XSS in the Frontend (1)
  • SW-20878: Non-Persistent XSS in the Frontend (2)

You can choose between two options, to protect your system:

Solutions

We strongly recommend to update to the latest version of Shopware (5.3.7). This Version will fix these vulnerabilities. You can use the auto-update process or simply download the version over our download page.

Install / update the security plugin

If it is not possible for you to update to the latest version of Shopware, you can use our Shopware Security-Plugin.

  • Download the Shopware Security Plugin from our store or use the Plugin Manager of your Shopware backend.
  • Install and activate the plugin.

If you use this plugin already, simply update it to the latest version to secure your environment.