Security Update 05/2018

Version

4.2.0 - 5.4.2

Table of contents

General information

Next to the usual bug fixes and optimizations, we have also been able to close multiple vulnerabilities at the "moderate to very low" threat level.
All Shopware Versions from 4.2.0 up to 5.4.2 are affected. The following vulnerabilities are fixed with this release.

  • SW-21640: Information leakage
  • SW-21593: Unauthorized currency change in ordering process
  • SW-21404: Authenticated SQL Injection in the backend
  • SW-21151: Authenticated path traversal attack in the REST API
  • SW-21412: Authenticated path traversal attack in the backend

You can choose between two options, to protect your system:

Solutions

We strongly recommend to update to the latest version of Shopware (5.4.3). This Version will fix these vulnerabilities. You can use the auto-update process or simply download the version over our download page.

Install / update the security plugin

If it is not possible for you to update to the latest version of Shopware, you can use our Shopware Security-Plugin.

  • Download the Shopware Security Plugin from our store or use the Plugin Manager of your Shopware backend.
  • Install and activate the plugin.

If you use this plugin already, simply update it to the latest version to secure your environment. Also if you experience any problems, you can disable individual fixes via the plugin settings.

Please check all important functionalities, in particular the ordering process, after installation or update