Migration - System Requirements

Version

6.0.0 or newer

Table of contents

Before you install Shopware 6, you should check that your server meets the system requirements. In this article we will show you what requirements your server should have and how you can easily check this with the Shopware Migration Wizard.

System requirements

Operating system

Shopware generally supports most Unix-based operating systems. From experience we recommend to install Shopware 6 on Ubuntu 18.04 LTS or macOS Mojave 10.14.

Environment

PHP

7.2 or higher
memory_limit 512M or higher
max_execution_time 30 seconds or higher
Composer 1.6 or higher

Extensions:

  • ext-dom
  • ext-fileinfo
  • ext-gd
  • ext-iconv
  • ext-intl
  • ext-json
  • ext-libxml
  • ext-mbstring
  • ext-openssl
  • ext-pcre
  • ext-pdo
  • ext-pdo_mysql
  • ext-phar
  • ext-simplexml
  • ext-xml
  • ext-zip
  • ext-zlib


SQL

MySQL 5.7.21 or higher
or
MariaDB 10.3 or higher
In each case with the configuration group_concat_max_len=320000



JavaScript

Node.js 8.10.0 or higher
NPM 6.5.0 or higher



Other

Apache 2.4 or higher with active mod-rewrite
Bash
Git

 

Zend Opcache 256M or higher
APCu 128M or higher
Webserver with HTTP2 support
For database administration we recommend Adminer (https://www.adminer.org/) because it has better support for binary data types.

 

Shopware Migrationsassistent

The Shopware Migrationassistent helps you to check if your current server and installed plugins meet the requirements to be migrated to Shopware 6. You can find the Shopware Migration Wizard for your Shopware 5 installation in the Shopware Plugin Store.
After you have installed and activated the plugin, reload the backend once. Click on the question mark symbol in the menu bar to find the Shopware 6 Update Check menu item.

 

Requirements

The Requirements tab shows you which requirements for Shopware 6 your server currently already meets, and where you should configure your server before migration.

Plugins

The tab Plugins shows you for your installed plugins whether they are also available for Shopware 6 and the configurations can be adopted.

Previous step    Next step



 

Was this article helpful?