Migration - System requirements

Before you install Shopware 6, you should check that your server meets the system requirements. In this article, we will show you what requirements your server should have and how you can easily check this with the Shopware Migration Wizard (only for Shopware 5).

System requirements

Operating system

Shopware generally supports most Unix-based operating systems. From experience, we recommend installing Shopware 6 on Ubuntu 18.04 LTS or macOS Mojave 10.14.

Please note that the requirements listed below are the minimum system requirements. Depending on how the shop is used (extensions, number of products, etc.), it is advisable to increase these accordingly.

Environment

PHP

8.1 or higher
memory_limit 512M or higher
max_execution_time 30 seconds or higher
Composer 2.0 or higher

Extensions:

  • ext-dom
  • ext-fileinfo
  • ext-gd
  • ext-iconv
  • ext-intl
  • ext-json
  • ext-libxml
  • ext-mbstring
  • ext-openssl
  • ext-pcre
  • ext-pdo
  • ext-pdo_mysql
  • ext-phar
  • ext-simplexml
  • ext-xml
  • ext-zip
  • ext-zlib



SQL

  • MySQL 8.0 or higher
    MySQL versions 8.0.20 and 8.0.21 are not compatible due to technical problems in these versions.

or

  • MariaDB 10.3.22 or higher
    MariaDB versions 10.3.29, 10.4.19 and 10.5.10 are not compatible due to technical problems in these versions.


JavaScript

Node.js 18.x.x or higher
NPM 6.5.0 or higher



Other

Apache 2.4 or higher with active mod-rewrite
Bash
Git

GIT
For version 6.5.0.0 or if you want to update from version 6.4 to version 6.5.0.0 and above, a git client must be installed on the server and a connection to our git repository has to be possible.
An update will fail without the git client and connection to the repository.

Zend Opcache 256M or higher
Webserver with HTTP2 support
For database administration, we recommend Adminer (https://www.adminer.org/) because it has better support for binary data types.

Shopware Migrationsassistent

If you are migrating from Shopware 5, the Shopware Migration Wizard will help you verify that the server of your current Shopware 5 installation and installed plugins meet the requirements to be migrated to Shopware 6. You can find the Shopware Migration Wizard for your Shopware 5 installation in the Shopware Plugin Store.

After you have installed and activated the plugin, reload the backend once. Click on the question mark symbol in the menu bar to find the Shopware 6 Update Check menu item.

Requirements

The Requirements tab shows you which requirements for Shopware 6 your server currently already meets, and where you should configure your server before migration.

Plugins

The tab Plugins shows you for your installed plugins whether they are also available for Shopware 6 and the configurations can be adopted.

Was this article helpful?