Security Update 07/2020

Version

6.1.0 - 6.2.2

General Information

In this security release, we have been able to close security gaps of the threat level "low" and "medium" in addition to the usual error corrections and optimizations. Affected are the Shopware versions from 6.1.0 up to and including 6.2.2. The following vulnerability has been fixed with this security update:

NEXT-9176 - Authenticated stored XSS
NEXT-9175 - Authenticated Server Side Request Forgery
NEXT-9174 - Information Leakage when the development environment is active
NEXT-9240 - Authenticated stored XSS
NEXT-9569 - Session hijacking vulnerability of customer accounts in the storefront

We recommend to update to the current version 6.2.3. You can get the update to 6.2.3 regularly via the Auto-Updater or directly via the download overview.

https://www.shopware.com/en/download/#shopware-6

For older versions of 6.1 the corresponding changes are also available via plugin:

Shopware 6 Security Plugin

Was this article helpful?